<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://glossynews.com/xmlrpc.php">

	<!-- This site is optimized with the Yoast SEO plugin v14.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>To BE or NOT to Be Politically Involved...THAT is the Question! - Glossy News Satire</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="To BE or NOT to Be Politically Involved...THAT is the Question! - Glossy News Satire" />
	<meta property="og:description" content="Distraction #1: Turn away! You&#8217;re probably watching the Crime-and-Investigation channel rather than CNN or MSNBC, right? You just have to take your mind off of real-time, political crimes and investigations going on in this divisive political era. Allow me to..." />
	<meta property="og:url" content="http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/" />
	<meta property="og:site_name" content="Glossy News Satire" />
	<meta property="article:publisher" content="http://facebook.com/glossynews" />
	<meta property="article:published_time" content="2020-10-11T14:05:34+00:00" />
	<meta property="article:modified_time" content="2020-10-11T14:05:35+00:00" />
	<meta property="og:image" content="https://i2.wp.com/glossynews.com/wp-content/uploads/2020/10/istockphoto-90848867-170667a.jpeg?fit=320%2C213" />
	<meta property="og:image:width" content="320" />
	<meta property="og:image:height" content="213" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://glossynews.com/#organization","name":"Glossy News Satire","url":"http://glossynews.com/","sameAs":["http://facebook.com/glossynews","https://www.youtube.com/user/10kzebra","https://www.pinterest.co.uk/glossynews/"],"logo":{"@type":"ImageObject","@id":"http://glossynews.com/#logo","inLanguage":"en-US","url":"","caption":"Glossy News Satire"},"image":{"@id":"http://glossynews.com/#logo"}},{"@type":"WebSite","@id":"http://glossynews.com/#website","url":"http://glossynews.com/","name":"Glossy News Satire","description":"WE ARE FAKE NEWS!","publisher":{"@id":"http://glossynews.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"http://glossynews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/glossynews.com/wp-content/uploads/2020/10/istockphoto-90848867-170667a.jpeg?fit=320%2C213","width":320,"height":213,"caption":"Female woman looking into the television as she holds it and screams at it. Telelvision Frustrations."},{"@type":"WebPage","@id":"http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#webpage","url":"http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/","name":"To BE or NOT to Be Politically Involved...THAT is the Question! - Glossy News Satire","isPartOf":{"@id":"http://glossynews.com/#website"},"primaryImageOfPage":{"@id":"http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#primaryimage"},"datePublished":"2020-10-11T14:05:34+00:00","dateModified":"2020-10-11T14:05:35+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/"]}]},{"@type":"Article","@id":"http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#article","isPartOf":{"@id":"http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#webpage"},"author":{"@id":"http://glossynews.com/#/schema/person/c0d6e62cc55f1f3512401768eefaa7dd"},"headline":"To BE or NOT to Be Politically Involved&#8230;THAT is the Question!","datePublished":"2020-10-11T14:05:34+00:00","dateModified":"2020-10-11T14:05:35+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#webpage"},"publisher":{"@id":"http://glossynews.com/#organization"},"image":{"@id":"http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#primaryimage"},"keywords":"distractions,politically involved,politics","articleSection":"Politics,Top Stories","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#respond"]}]},{"@type":["Person"],"@id":"http://glossynews.com/#/schema/person/c0d6e62cc55f1f3512401768eefaa7dd","name":"Kelly Jackson"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Glossy News Satire &raquo; Feed" href="http://glossynews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Glossy News Satire &raquo; Comments Feed" href="http://glossynews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Glossy News Satire &raquo; To BE or NOT to Be Politically Involved&#8230;THAT is the Question! Comments Feed" href="http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/glossynews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='maxwp-maincss-css'  href='http://glossynews.com/wp-content/themes/maxwp/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='maxwp-child-css'  href='http://glossynews.com/wp-content/themes/maxwp-child/style.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://glossynews.com/wp-content/themes/maxwp/assets/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='maxwp-webfont-css'  href='//fonts.googleapis.com/css?family=Playfair+Display:400,400i,700,700i|Domine:400,700|Oswald:400,700|Patua+One' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://glossynews.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.5/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='http://glossynews.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://glossynews.com/wp-content/themes/maxwp/assets/js/html5shiv.min.js'></script>
<![endif]-->
<!--[if lt IE 9]>
<script type='text/javascript' src='http://glossynews.com/wp-content/themes/maxwp/assets/js/respond.min.js'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://glossynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://glossynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://glossynews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://wp.me/pE8CS-liA' />
<link rel="alternate" type="application/json+oembed" href="http://glossynews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.onclick=1;
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>

<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>    <style type="text/css">
            .maxwp-site-title, .maxwp-site-description {position: absolute;clip: rect(1px, 1px, 1px, 1px);}
        </style>
    <style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("http://glossynews.com/wp-content/themes/maxwp/assets/images/background.png"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: fixed; }
</style>
	<script data-ad-client="ca-pub-9186071007459948" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>

<body class="post-template-default single single-post postid-81876 single-format-standard custom-background wp-custom-logo maxwp-animated maxwp-fadein maxwp-group-blog" id="maxwp-site-body" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<a class="skip-link screen-reader-text" href="#maxwp-posts-wrapper">Skip to content</a>


<div class="maxwp-container" id="maxwp-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader" role="banner">
<div class="maxwp-outer-wrapper">
<div class="maxwp-head-content clearfix" id="maxwp-head-content">


<div class="maxwp-header-inside clearfix">
<div id="maxwp-logo">
    <div class="site-branding">
    <a href="http://glossynews.com/" rel="home" class="maxwp-logo-img-link">
        <img src="https://i1.wp.com/glossynews.com/wp-content/uploads/2019/12/Glossy-News-Satire-800.png?fit=800%2C61" alt="" class="maxwp-logo-img"/>
    </a>
    </div>
</div><!--/#maxwp-logo -->

<div id="maxwp-header-banner">
</div><!--/#maxwp-header-banner -->

</div>

</div><!--/#maxwp-head-content -->
</div>
</div><!--/#maxwp-header -->


<div class="maxwp-container maxwp-primary-menu-container clearfix">
<div class="maxwp-outer-wrapper">
<div class="maxwp-primary-menu-container-inside clearfix">
<nav class="maxwp-nav-primary" id="maxwp-primary-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation" aria-label="Primary Menu">
<button class="maxwp-primary-responsive-menu-icon" aria-controls="maxwp-menu-primary-navigation" aria-expanded="false">Menu</button>
<ul id="maxwp-menu-primary-navigation" class="maxwp-primary-nav-menu maxwp-menu-primary"><li ><a href="http://glossynews.com/">Home</a></li><li class="page_item page-item-65550"><a href="http://glossynews.com/contact-advertise/">Advertise with Glossy News</a></li><li class="page_item page-item-67512"><a href="http://glossynews.com/67512-2/">Submit Your Satire Here!</a></li><li class="page_item page-item-65571"><a href="http://glossynews.com/terms-of-use/">Terms of Use</a></li></ul>
<div class='maxwp-top-social-icons'>
                    <a href="http://www.facebook.com/glossynews" target="_blank" class="maxwp-social-icon-facebook" title="Facebook"><i class="fa fa-facebook" aria-hidden="true"></i></a>                                    <a href="https://www.youtube.com/user/10kzebra" target="_blank" class="maxwp-social-icon-youtube" title="Youtube"><i class="fa fa-youtube" aria-hidden="true"></i></a>                                                                                            <a href="#" title="Search" class="maxwp-social-icon-search"><i class="fa fa-search"></i></a>
</div>

</nav>
</div>
</div>
</div>

<div id="maxwp-search-overlay-wrap" class="maxwp-search-overlay">
  <button class="maxwp-search-closebtn" aria-label="Close Search" title="Close Search">&#xD7;</button>
  <div class="maxwp-search-overlay-content">
    
<form role="search" method="get" class="maxwp-search-form" action="http://glossynews.com/">
<label>
    <span class="screen-reader-text">Search for:</span>
    <input type="search" class="maxwp-search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="maxwp-search-submit" value="Search" />
</form>  </div>
</div>


<div class="maxwp-outer-wrapper">


</div>

<div class="maxwp-outer-wrapper">

<div class="maxwp-container clearfix" id="maxwp-wrapper">
<div class="maxwp-content-wrapper clearfix" id="maxwp-content-wrapper">

<div class="maxwp-main-wrapper clearfix" id="maxwp-main-wrapper" itemscope="itemscope" itemtype="http://schema.org/Blog" role="main">
<div class="theiaStickySidebar">
<div class="maxwp-main-wrapper-inside clearfix">




<div class="maxwp-posts-wrapper" id="maxwp-posts-wrapper">


    
<article id="post-81876" class="maxwp-post-singular maxwp-box post-81876 post type-post status-publish format-standard has-post-thumbnail hentry category-politicos-and-polticians category-top-stories tag-distractions tag-politically-involved tag-politics wpcat-31-id wpcat-3-id">

    <header class="entry-header">
        <div class="maxwp-entry-meta-single maxwp-entry-meta-single-top"><span class="maxwp-entry-meta-single-cats"><i class="fa fa-folder-open-o" aria-hidden="true"></i>&nbsp;<span class="screen-reader-text">Posted in </span><a href="http://glossynews.com/category/top-stories/politicos-and-polticians/" rel="category tag">Politics</a>, <a href="http://glossynews.com/category/top-stories/" rel="category tag">Top Stories</a></span></div>
        <h1 class="post-title entry-title"><a href="http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/" rel="bookmark">To BE or NOT to Be Politically Involved&#8230;THAT is the Question!</a></h1>
                <div class="maxwp-entry-meta-single">
    <span class="maxwp-entry-meta-single-author"><i class="fa fa-user-circle-o" aria-hidden="true"></i>&nbsp;<span class="author vcard" itemscope="itemscope" itemtype="http://schema.org/Person" itemprop="author"><a class="url fn n" href="http://glossynews.com/author/kelly-jackson/"><span class="screen-reader-text">Author: </span>Kelly Jackson</a></span></span>    <span class="maxwp-entry-meta-single-date"><i class="fa fa-clock-o" aria-hidden="true"></i>&nbsp;<span class="screen-reader-text">Published Date: </span>October 11, 2020</span>        <span class="maxwp-entry-meta-single-comments"><i class="fa fa-comments-o" aria-hidden="true"></i>&nbsp;<a href="http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#respond">Leave a Comment<span class="screen-reader-text"> on To BE or NOT to Be Politically Involved&#8230;THAT is the Question!</span></a></span>
            </div>
        </header><!-- .entry-header -->

    <div class="entry-content clearfix">
                                        <a href="http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/" title="Permanent Link to To BE or NOT to Be Politically Involved&#8230;THAT is the Question!"><img width="320" height="213" src="https://i2.wp.com/glossynews.com/wp-content/uploads/2020/10/istockphoto-90848867-170667a.jpeg?resize=320%2C213" class="maxwp-post-thumbnail-single wp-post-image" alt="" srcset="https://i2.wp.com/glossynews.com/wp-content/uploads/2020/10/istockphoto-90848867-170667a.jpeg?w=320 320w, https://i2.wp.com/glossynews.com/wp-content/uploads/2020/10/istockphoto-90848867-170667a.jpeg?resize=200%2C133 200w, https://i2.wp.com/glossynews.com/wp-content/uploads/2020/10/istockphoto-90848867-170667a.jpeg?resize=100%2C67 100w" sizes="(max-width: 320px) 100vw, 320px" /></a>
                
<p>Distraction #1: Turn away!</p>



<p>You&#8217;re probably watching the Crime-and-Investigation channel rather than CNN or MSNBC, right? You just have to take your mind off of real-time, political crimes and investigations going on in this divisive political era. Allow me to offer up some other viewing options:</p>



<ul><li>The Food Network…for pity’s sake, it’s Halloween Wars Week, and the pumpkin carving is almost as scary as our politicians in Congress.</li><li>&nbsp;Nat/Geo…seriously? The animals are just chasing each other over hill, dale and desert in order to eat or be eaten!</li><li>ESPN…come ON!&nbsp; Even golf tournaments have no spectators.&nbsp;</li></ul>



<p>Books might be a better choice for keeping your head in the sand unless you’ve already ordered the 74 new political books coming out.</p>



<p>Distraction #2: Family and friends</p>



<p>Let’s be honest. As politically divided as some families are these days, you’re giddy that you never have to speak to Uncle Frank again. The pandemic has given you a voice, so you can tell him to f%*k off without regret.</p>



<p>You can now easily identify family members and their political leanings because they’re either wearing red or blue. It’s the relatives in purple who scare you…they’re not even voting. They just like purple.</p>



<p>If you’re able to forgo discussing politics with Aunt Sally, you’ll probably make it.&nbsp; Just focus on her Tiger King tee shirt and go there instead.</p>



<p>Distraction #3: Work…If you can</p>



<p>If you have work, you’re in the minority these days, so hold tight to your bully of a boss and your bi-polar-off-medication colleagues.</p>



<p>You can wear your mask with V O T E across your mouth because it’s neither left nor right. They can’t indict you for wearing a mask, can they?</p>



<p>Politicians work, I think. They do, don’t they? Their product has been harder to find of late, but they will tell you that they are working for YOU.&nbsp; If you buy that, make certain that your receipt holds an option for a refund.</p>



<p>Just try to hold onto your job if you have one. ‘Good help is hard to find,’ but good jobs are even harder to get!</p>



<p>Distraction #4: Eat and drink…go ahead!</p>



<p>Those who are intensely political are skinny, and they don’t drink much. Have their second Martini for them while they’re out marching.&nbsp;</p>



<p>In order to stay politically active, try all of these drinks:</p>



<ul><li>The Nasty Woman</li><li>The Bad Hombre</li><li>The Donald</li><li>The Putin and Tonic</li><li>The Rum and Comey</li></ul>



<p>As far as eating goes, just don’t weigh yourself until 2021, and even then, you might hold off until we’ve rejoined the Paris Climate Agreement.</p>



<p>Humans need sustenance, even political junkies.</p>



<p>Distraction #5: Get plenty of rest</p>



<p>Sleeping is NOT overrated. These times demand that everyone have enough energy to withstand all of the political ‘slings and arrows’ flying around. That requires rest.</p>



<p>There are two camps, obviously. Those who sleep like babies are either just not paying attention to politics of any kind right now or they’re on drugs. Either way, they are to be envied.</p>



<p>We all need sleep. Do whatever you have to to turn off your brain.&nbsp; Let’s discuss crazy dreams next time!</p>



<p>It’s time to make a choice.&nbsp; You can run but you cannot hide from politics!&nbsp;</p>

<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_36 addtoany_list" data-a2a-url="http://glossynews.com/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/" data-a2a-title="To BE or NOT to Be Politically Involved…THAT is the Question!"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved%E2%80%A6THAT%20is%20the%20Question%21" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved%E2%80%A6THAT%20is%20the%20Question%21" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved%E2%80%A6THAT%20is%20the%20Question%21" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved%E2%80%A6THAT%20is%20the%20Question%21" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved%E2%80%A6THAT%20is%20the%20Question%21" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div><!-- .entry-content -->

    <footer class="entry-footer">
        <span class="maxwp-tags-links"><i class="fa fa-tags" aria-hidden="true"></i> Tagged <a href="http://glossynews.com/tag/distractions/" rel="tag">distractions</a>, <a href="http://glossynews.com/tag/politically-involved/" rel="tag">politically involved</a>, <a href="http://glossynews.com/tag/politics/" rel="tag">politics</a></span>    </footer><!-- .entry-footer -->

    
            <div class="maxwp-author-bio">
            <div class="maxwp-author-bio-top">
            <div class="maxwp-author-bio-gravatar">
                
            </div>
            <div class="maxwp-author-bio-text">
                <h4>Author: <span>Kelly Jackson</span></h4>
            </div>
            </div>
            </div>
        
</article>
    
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://glossynews.com/entertainment/202010071030/spin-doctored-quotes-from-trumps-mcdreamy-and-other-doctors-hippocratic-or-hypocritical-oath/" rel="prev">&larr; Spin Doctored Quotes from Trump’s &#8220;McDreamy&#8221; and Other Doctors: Hippocratic or Hypocritical Oath?</a></div></div>
	</nav>
    
<div id="comments" class="comments-area maxwp-box">

    
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Wadayasay? Here&#039;s your chance to sound off!					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/top-stories/202010110705/to-be-or-not-to-be-politically-involved-that-is-the-question/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=9566282&#038;postid=81876&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=0&#038;avatar_default=blank&#038;greeting=Wadayasay%3F+Here%27s+your+chance+to+sound+off%21&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.5&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=772d97363d71af87a7f11e679d82fcd5cdf233e4#parent=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
<div class="clear"></div>

</div><!--/#maxwp-posts-wrapper -->


<div class='maxwp-featured-posts-area maxwp-featured-posts-area-bottom clearfix'>

<div id="custom_html-6" class="widget_text maxwp-main-widget widget maxwp-box widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-9186071007459948"
     data-ad-slot="1669486618"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div>


</div>
</div>
</div><!-- /#maxwp-main-wrapper -->


<div class="maxwp-sidebar-one-wrapper maxwp-sidebar-widget-areas clearfix" id="maxwp-sidebar-one-wrapper" itemscope="itemscope" itemtype="http://schema.org/WPSideBar" role="complementary">
<div class="theiaStickySidebar">
<div class="maxwp-sidebar-one-wrapper-inside clearfix">

<div id="a2a_share_save_widget-2" class="maxwp-side-widget widget maxwp-box widget_a2a_share_save_widget"><h2 class="maxwp-widget-title"><span>Share Glossy News!</span></h2><div class="a2a_kit a2a_kit_size_36 addtoany_list"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved...THAT%20is%20the%20Question%21%20-%20Glossy%20News%20Satire" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved...THAT%20is%20the%20Question%21%20-%20Glossy%20News%20Satire" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved...THAT%20is%20the%20Question%21%20-%20Glossy%20News%20Satire" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved...THAT%20is%20the%20Question%21%20-%20Glossy%20News%20Satire" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F&amp;linkname=To%20BE%20or%20NOT%20to%20Be%20Politically%20Involved...THAT%20is%20the%20Question%21%20-%20Glossy%20News%20Satire" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div id="custom_html-2" class="widget_text maxwp-side-widget widget maxwp-box widget_custom_html"><h2 class="maxwp-widget-title"><span>Our &#8220;How it&#8217;s REALLY Made&#8221; Series</span></h2><div class="textwidget custom-html-widget"><center>
	<iframe width="300" height="169" src="https://www.youtube.com/embed/playlist?list=PLCdNMfh6k1PkmFfDuOjLxCHlvtkUMNEY2" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</center></div></div><div id="custom_html-3" class="widget_text maxwp-side-widget widget maxwp-box widget_custom_html"><h2 class="maxwp-widget-title"><span>Mad Mad Monkey Men</span></h2><div class="textwidget custom-html-widget"><center>
	<iframe width="300" height="169" src="https://www.youtube.com/embed/playlist?list=PLR4RnZ9vQVqmBOJLy1FbetGLWeT_9SI6n" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</center></div></div><div id="custom_html-4" class="widget_text maxwp-side-widget widget maxwp-box widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- GN-5-2020-square -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9186071007459948"
     data-ad-slot="6566304660"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="custom_html-5" class="widget_text maxwp-side-widget widget maxwp-box widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- GN-5-2020-linkads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9186071007459948"
     data-ad-slot="4710582929"
     data-ad-format="link"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<br />
<br />
<a href="https://www.northgateacademy.com">Homeschooling Online</a> at Northgate Academy</div></div>
</div>
</div>
</div><!-- /#maxwp-sidebar-one-wrapper-->

</div>

</div><!--/#maxwp-content-wrapper -->
</div><!--/#maxwp-wrapper -->




<div class="maxwp-outer-wrapper">
<div class='clearfix' id='maxwp-footer'>
<div class='maxwp-foot-wrap maxwp-container'>

  <p class='maxwp-copyright'>Copyright &copy; 2020 Glossy News Satire</p>
<p class='maxwp-credit'><a href="https://themesdna.com/">Design by ThemesDNA.com</a></p>

</div>
</div><!--/#maxwp-footer -->
</div>

<button class="maxwp-scroll-top" title="Scroll to Top"><span class="fa fa-arrow-up" aria-hidden="true"></span><span class="screen-reader-text">Scroll to Top</span></button>

 
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-9186071007459948"
     data-ad-slot="7635843750"></ins> 
<script>
     (adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
  <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='http://glossynews.com/wp-content/themes/maxwp/assets/js/jquery.fitvids.min.js'></script>
<script type='text/javascript' src='http://glossynews.com/wp-content/themes/maxwp/assets/js/ResizeSensor.min.js'></script>
<script type='text/javascript' src='http://glossynews.com/wp-content/themes/maxwp/assets/js/theia-sticky-sidebar.min.js'></script>
<script type='text/javascript' src='http://glossynews.com/wp-content/themes/maxwp/assets/js/navigation.js'></script>
<script type='text/javascript' src='http://glossynews.com/wp-content/themes/maxwp/assets/js/skip-link-focus-fix.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var maxwp_ajax_object = {"ajaxurl":"http:\/\/glossynews.com\/wp-admin\/admin-ajax.php","primary_menu_active":"1","secondary_menu_active":"","sticky_menu":"1","sticky_menu_mobile":"","sticky_sidebar":"1","slider":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://glossynews.com/wp-content/themes/maxwp/assets/js/custom.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/wp-embed.min.js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=9566282&postid=81876&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=0&avatar_default=blank&greeting=Wadayasay%3F+Here%27s+your+chance+to+sound+off%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=772d97363d71af87a7f11e679d82fcd5cdf233e4#parent=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=9566282&postid=81876&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=0&avatar_default=blank&greeting=Wadayasay%3F+Here%27s+your+chance+to+sound+off%21&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=772d97363d71af87a7f11e679d82fcd5cdf233e4#parent=http%3A%2F%2Fglossynews.com%2Ftop-stories%2F202010110705%2Fto-be-or-not-to-be-politically-involved-that-is-the-question%2F";
					}
				};

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202041.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'9566282',post:'81876',tz:'-7',srv:'glossynews.com'} ]);
	_stq.push([ 'clickTrackerInit', '9566282', '81876' ]);
</script>
</body>
</html>
<!-- Dynamic page generated in 0.093 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-10-11 07:06:03 -->

<!-- Compression = gzip -->